<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://vmusketeers.com/xmlrpc.php" />
<title>Mapping the VCDX Defense Genome Part 3: Is All Flash a Trap?! &#8211; vMusketeers</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//player.vimeo.com' />
<link rel='dns-prefetch' href='//w.soundcloud.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="vMusketeers &raquo; Feed" href="http://vmusketeers.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="vMusketeers &raquo; Comments Feed" href="http://vmusketeers.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="vMusketeers &raquo; Mapping the VCDX Defense Genome Part 3: Is All Flash a Trap?! Comments Feed" href="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/vmusketeers.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.9"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='formidable-css'  href='http://vmusketeers.com/wp-content/uploads/formidable/css/formidablepro.css?ver=10291932' type='text/css' media='all' />
<link rel='stylesheet' id='drawit-css-css'  href='http://vmusketeers.com/wp-content/plugins/drawit/css/drawit.min.css?ver=1.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='mystyle-5-css'  href='http://vmusketeers.com/wp-content/plugins/gallery-pro/css/display_frant_css.css?ver=4.6.9' type='text/css' media='all' />
<link rel='stylesheet' id='mystyle-6-css'  href='http://vmusketeers.com/wp-content/plugins/gallery-pro/css/bootstrap.css?ver=4.6.9' type='text/css' media='all' />
<link rel='stylesheet' id='mystyle-8-css'  href='http://vmusketeers.com/wp-content/plugins/gallery-pro/js/grid-folio/jquery.wm-gridfolio-1.0.min.css?ver=4.6.9' type='text/css' media='all' />
<link rel='stylesheet' id='wl-lksg-swipe-css-css'  href='http://vmusketeers.com/wp-content/plugins/gallery-pro/lightbox/swipebox/css/swipebox.css?ver=4.6.9' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='http://vmusketeers.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.7' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('http://vmusketeers.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wpProQuiz_front_style-css'  href='http://vmusketeers.com/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-lite-css'  href='http://vmusketeers.com/wp-content/themes/mh-magazine-lite/style.css?ver=4.6.9' type='text/css' media='all' />
<link rel='stylesheet' id='mh-techmagazine-css'  href='http://vmusketeers.com/wp-content/themes/mh-techmagazine/style.css?ver=1.0.8' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400,400italic,700,600' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='http://vmusketeers.com/wp-content/themes/mh-magazine-lite/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://vmusketeers.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://vmusketeers.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.6' type='text/css' media='all' />
<script type='text/javascript' src='http://vmusketeers.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/gallery-pro/js/grid-folio/jquery.wm-gridfolio-1.0.min.js?ver=4.6.9'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/gallery-pro/lightbox/swipebox/js/jquery.swipebox.js?ver=4.6.9'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.7.1'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-social-tracker.js?ver=1.7.1'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-youtube.js?ver=1.7.1'></script>
<script type='text/javascript' src='https://player.vimeo.com/api/player.js?ver=1.0'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-vimeo.js?ver=1.7.1'></script>
<script type='text/javascript' src='https://w.soundcloud.com/player/api.js?ver=1.0'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-soundcloud.js?ver=1.7.1'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/duracelltomi-google-tag-manager/js/analytics-talk-content-tracking.js?ver=1.7.1'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/themes/mh-magazine-lite/js/scripts.js?ver=4.6.9'></script>
<script type='text/javascript' async defer src='https://apis.google.com/js/platform.js?ver=4.6.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var quicktagsL10n = {"closeAllOpenTags":"Close all open tags","closeTags":"close tags","enterURL":"Enter the URL","enterImageURL":"Enter the URL of the image","enterImageDescription":"Enter a description of the image","textdirection":"text direction","toggleTextdirection":"Toggle Editor Text Direction","dfw":"Distraction-free writing mode","strong":"Bold","strongClose":"Close bold tag","em":"Italic","emClose":"Close italic tag","link":"Insert link","blockquote":"Blockquote","blockquoteClose":"Close blockquote tag","del":"Deleted text (strikethrough)","delClose":"Close deleted text tag","ins":"Inserted text","insClose":"Close inserted text tag","image":"Insert image","ul":"Bulleted list","ulClose":"Close bulleted list tag","ol":"Numbered list","olClose":"Close numbered list tag","li":"List item","liClose":"Close list item tag","code":"Code","codeClose":"Close code tag","more":"Insert Read More tag"};
/* ]]> */
</script>
<script type='text/javascript' src='http://vmusketeers.com/wp-includes/js/quicktags.min.js?ver=4.6.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var drawitFE = {"mediaupload":"http:\/\/vmusketeers.com\/wp-admin\/\/media-upload.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/drawit/js/qt-btn.js?ver=1.1.3'></script>
<link rel='https://api.w.org/' href='http://vmusketeers.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://vmusketeers.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://vmusketeers.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='RAVELLO: Windows vCenter 6.5 vCenter server errors: 500, 503' href='http://vmusketeers.com/2017/12/20/ravello-windows-vcenter-6-5-vcenter-server-errors-500-503/' />
<meta name="generator" content="WordPress 4.6.9" />
<link rel="canonical" href="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/" />
<link rel='shortlink' href='http://wp.me/p7uIJu-Qv' />
<link rel="alternate" type="application/json+oembed" href="http://vmusketeers.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fvmusketeers.com%2F2018%2F01%2F05%2Fmapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://vmusketeers.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fvmusketeers.com%2F2018%2F01%2F05%2Fmapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap%2F&#038;format=xml" />

<!-- Google Tag Manager for WordPress by DuracellTomi - http://duracelltomi.com -->
<script data-cfasync="false" type="text/javascript">
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];

	var gtm4wp_scrollerscript_debugmode         = false;
	var gtm4wp_scrollerscript_callbacktime      = 100;
	var gtm4wp_scrollerscript_readerlocation    = 150;
	var gtm4wp_scrollerscript_contentelementid  = "content";
	var gtm4wp_scrollerscript_scannertime       = 60;
	dataLayer.push({"visitorLoginState":"logged-out","pageTitle":"Mapping the VCDX Defense Genome Part 3: Is All Flash a Trap?! | ","pagePostType":"post","pagePostType2":"single-post","pageCategory":["design","vcdx","vmware"],"pagePostAuthorID":8,"pagePostAuthor":"Jason Grierson","pagePostDate":"January 5, 2018","pagePostDateYear":"2018","pagePostDateMonth":"01","pagePostDateDay":"05","postCountOnPage":1,"postCountTotal":1,"postID":3255});
</script>
<script data-cfasync="false">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5FBHLM');</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by DuracellTomi -->
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]>
<script src="http://vmusketeers.com/wp-content/themes/mh-magazine-lite/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url('http://vmusketeers.com/blog/wp-content/uploads/2016/04/background1.png'); background-repeat: repeat; background-position: top left; background-attachment: scroll; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Mapping the VCDX Defense Genome Part 3: Is All Flash a Trap?!" />
<meta property="og:url" content="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/" />
<meta property="og:description" content="Hey everyone, So prior to the holidays I was helping mentor some new VCDX candidates for their re-defenses and was coming across a few trends that I wanted to discuss a little as they started creep…" />
<meta property="article:published_time" content="2018-01-05T22:00:38+00:00" />
<meta property="article:modified_time" content="2018-01-05T23:07:49+00:00" />
<meta property="og:site_name" content="vMusketeers" />
<meta property="og:image" content="http://vmusketeers.com/wp-content/uploads/2018/01/ItsATrap.png" />
<meta property="og:image:width" content="832" />
<meta property="og:image:height" content="632" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@vmusketeers" />
<meta name="twitter:card" content="summary" />
<link rel="icon" href="https://i1.wp.com/vmusketeers.com/wp-content/uploads/2016/04/cropped-vm.jpg?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/vmusketeers.com/wp-content/uploads/2016/04/cropped-vm.jpg?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/vmusketeers.com/wp-content/uploads/2016/04/cropped-vm.jpg?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/vmusketeers.com/wp-content/uploads/2016/04/cropped-vm.jpg?fit=270%2C270" />
<!-- BEGIN GADWP v5.1.2.5 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-77996231-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
			<link rel="stylesheet" id="custom-css-css" type="text/css" href="http://vmusketeers.com/?custom-css=1&#038;csblog=1&#038;cscache=6&#038;csrev=59" />
			</head>
<body id="mh-mobile" class="single single-post postid-3255 single-format-standard custom-background mh-right-sb">
<div class="mh-header-mobile-nav clearfix"></div>
<header class="mh-header">
	<div class="mh-container mh-container-inner mh-row clearfix">
		<div class="mh-custom-header" role="banner">
<a href="http://vmusketeers.com/" title="vMusketeers" rel="home">
<div class="mh-site-logo" role="banner">
<div class="mh-header-text">
<h2 class="mh-header-title">vMusketeers</h2>
<h3 class="mh-header-tagline">All Things Cloud</h3>
</div>
</div>
</a>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-main-nav mh-container mh-container-inner clearfix">
			<div class="menu-menu-container"><ul id="menu-menu" class="menu"><li id="menu-item-251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-251"><a href="http://vmusketeers.com/">Home</a></li>
<li id="menu-item-243" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-243"><a href="http://vmusketeers.com/news/">News</a></li>
<li id="menu-item-99" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-99"><a href="http://vmusketeers.com/certification/">Certification</a>
<ul class="sub-menu">
	<li id="menu-item-260" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-260"><a href="http://vmusketeers.com/certification/quizlets-disclaimer/">Quizlets Disclaimer</a></li>
	<li id="menu-item-458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-458"><a href="http://www.virtualtiers.net/">VCAP5-DCD Simulator</a></li>
	<li id="menu-item-1329" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1329"><a href="http://vmusketeers.com/vcap5-resources/">VCAP5 Resources</a></li>
	<li id="menu-item-1191" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1191"><a href="http://vmusketeers.com/vcp6-dcv-quiz/">VCP6-DCV Quiz</a></li>
	<li id="menu-item-159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159"><a href="http://vmusketeers.com/vcap6-dcv-design-quiz/">VCAP6-DCV Design Quiz</a></li>
	<li id="menu-item-2474" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2474"><a href="http://vmusketeers.com/vcap6-dcv-design-resource-page/">VCAP6-DCV Design resources</a></li>
</ul>
</li>
<li id="menu-item-272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-272"><a href="http://vmusketeers.com/tools/">Tips &#038; Tools</a>
<ul class="sub-menu">
	<li id="menu-item-2850" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2850"><a href="http://vmusketeers.com/the-business-perspective/">The Business Perspective</a>
	<ul class="sub-menu">
		<li id="menu-item-2853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2853"><a href="http://vmusketeers.com/introduction/">Introduction</a></li>
		<li id="menu-item-2874" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2874"><a href="http://vmusketeers.com/architecture-and-business/">Design, Architecture and the Business Perspective</a></li>
	</ul>
</li>
	<li id="menu-item-3207" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3207"><a href="http://vmusketeers.com/vsan-6-6-1-resources-calculator/">VSAN 6.5 AND 6.6.1 RESOURCES CALCULATOR</a></li>
	<li id="menu-item-1530" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1530"><a href="http://vmusketeers.com/vsan-6-2-resources-calculator/">VSAN 6.2 Resources Calculator</a></li>
	<li id="menu-item-1135" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1135"><a href="http://vmusketeers.com/vsan-6-0-on-disk-version-v2-calculator/">VSAN 6.0 On-Disk version v2 Calculator</a></li>
	<li id="menu-item-718" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-718"><a href="http://vmusketeers.com/virtualizing-business-critical-applications-bcas-on-vmware-vsphere-5/">Virtualizing Business Critical Applications on vSphere 5.x</a>
	<ul class="sub-menu">
		<li id="menu-item-727" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-727"><a href="http://vmusketeers.com/2015/01/21/virtualizing-microsoft-active-directory-domain-services-ad-ds-windows-2012-on-vsphere-5-best-practices/">Microsoft Active Directory Domain Services (AD DS)-Windows 2012</a></li>
		<li id="menu-item-720" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-720"><a href="http://vmusketeers.com/2015/02/12/virtualizing-microsoft-exchange-20102013-on-vsphere-5-best-practices/">Microsoft Exchange 2010/2013</a></li>
		<li id="menu-item-721" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-721"><a href="http://vmusketeers.com/2015/02/06/virtualizing-java-enterprise-applications-on-vsphere-5-best-practices/">Java Enterprise Applications</a></li>
		<li id="menu-item-726" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-726"><a href="http://vmusketeers.com/2015/01/22/virtualizing-microsoft-clustering-services-mscs-windows-2012-on-vsphere-5-best-practices/">Microsoft Clustering Services (MSCS)</a></li>
		<li id="menu-item-723" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-723"><a href="http://vmusketeers.com/2015/02/03/virtualizing-oracle-databases-on-vsphere-5-best-practices/">Oracle Databases</a></li>
		<li id="menu-item-722" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-722"><a href="http://vmusketeers.com/2015/02/05/virtualizing-sap-hana-on-vsphere-5-best-practices/">SAP HANA</a></li>
		<li id="menu-item-724" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-724"><a href="http://vmusketeers.com/2015/01/28/virtualizing-microsoft-sql-server-20122014-on-vsphere-5-best-practices/">Microsoft SQL Server 2012/2014</a></li>
		<li id="menu-item-725" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-725"><a href="http://vmusketeers.com/2015/01/26/virtualizing-microsoft-sharepoint-20102013-on-vsphere-5-best-practices/">Microsoft SharePoint 2010/2013</a></li>
	</ul>
</li>
	<li id="menu-item-719" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-719"><a href="http://vmusketeers.com/vsphere-5-x-design-thoughts-and-considerations/">vSphere 5.x Design Thoughts and Considerations</a></li>
	<li id="menu-item-273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-273"><a href="http://vmusketeers.com/vsphere-cluster-calculator/">vSphere Cluster Calculator</a>
	<ul class="sub-menu">
		<li id="menu-item-292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-292"><a href="http://vmusketeers.com/userguide-vsphere-cluster-calculator/">Userguide – vSphere Cluster Calculator</a></li>
	</ul>
</li>
	<li id="menu-item-326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-326"><a href="http://vmusketeers.com/poweractions/">PowerActions</a>
	<ul class="sub-menu">
		<li id="menu-item-324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-324"><a href="http://vmusketeers.com/for-datacenters/">For Datacenters</a>
		<ul class="sub-menu">
			<li id="menu-item-355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-355"><a href="http://vmusketeers.com/show-all-tags/">Show All Tags</a></li>
		</ul>
</li>
		<li id="menu-item-325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-325"><a href="http://vmusketeers.com/for-cluster-resources/">For Cluster Resources</a>
		<ul class="sub-menu">
			<li id="menu-item-356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-356"><a href="http://vmusketeers.com/show-all-the-vms-in-the-cluster-with-tag-yourtag/">Show All the VMs in the cluster with TAG “YourTag”</a></li>
		</ul>
</li>
		<li id="menu-item-322" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-322"><a href="http://vmusketeers.com/for-datastores/">For Datastores</a>
		<ul class="sub-menu">
			<li id="menu-item-347" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-347"><a href="http://vmusketeers.com/show-datastore-information-including-vmfs-filesystem-version/">SHow Datastore Information including VMFS Filesystem version</a></li>
		</ul>
</li>
		<li id="menu-item-323" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-323"><a href="http://vmusketeers.com/for-vms/">For VMs</a>
		<ul class="sub-menu">
			<li id="menu-item-351" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-351"><a href="http://vmusketeers.com/add-new-paravirtual-hdd-40gb-persistent/">Add new ParaVirtual HDD 40GB persistent</a></li>
			<li id="menu-item-352" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-352"><a href="http://vmusketeers.com/add-new-hdd-60gb-persistent/">Add new HDD 60GB persistent</a></li>
			<li id="menu-item-353" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-353"><a href="http://vmusketeers.com/consolidate-snapshots-for-multiple-vms/">Consolidate snapshots for multiple VMs</a></li>
			<li id="menu-item-354" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-354"><a href="http://vmusketeers.com/get-snapshots-for-multiple-selected-vms/">Get snapshots for multiple selected VMs</a></li>
			<li id="menu-item-348" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-348"><a href="http://vmusketeers.com/show-statistics-for-the-selected-vm/">Show Statistics for the selected VM</a></li>
			<li id="menu-item-350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-350"><a href="http://vmusketeers.com/show-nic-info-of-selected-vms/">Show NIC Info of selected VM’s</a></li>
			<li id="menu-item-349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-349"><a href="http://vmusketeers.com/show-all-files-of-selected-vms-in-the-storage-pools/">Show all files of selected VMs in the Storage Pools</a></li>
		</ul>
</li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-1468" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1468"><a href="http://vmusketeers.com/reviews/">Books &#038; Videos Review</a></li>
<li id="menu-item-2300" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2300"><a href="http://vmusketeers.com/product-reviews/">Product Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-2546" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2546"><a href="http://vmusketeers.com/10-zig/">10 ZiG</a></li>
	<li id="menu-item-2547" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2547"><a href="http://vmusketeers.com/pensa-networks/">Pensa Networks</a></li>
</ul>
</li>
<li id="menu-item-429" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-429"><a href="http://vmusketeers.com/coffee-corner/">Coffee Corner</a></li>
<li id="menu-item-180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-180"><a href="http://vmusketeers.com/about-us/">About Us</a>
<ul class="sub-menu">
	<li id="menu-item-730" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-730"><a href="http://vmusketeers.com/about-us/legal-disclaimer/">Legal Disclaimer</a></li>
	<li id="menu-item-399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-399"><a href="http://vmusketeers.com/about-us/bilal-ahmed/">Bilal Ahmed</a></li>
	<li id="menu-item-477" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-477"><a href="http://vmusketeers.com/don-ward/">Don Ward</a></li>
	<li id="menu-item-382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-382"><a href="http://vmusketeers.com/about-us/graeme-vermeulen/">Graeme Vermeulen</a></li>
	<li id="menu-item-848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-848"><a href="http://vmusketeers.com/about-us/jason-grierson/">Jason Grierson</a></li>
	<li id="menu-item-383" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-383"><a href="http://vmusketeers.com/kim-bottu/">Kim Bottu</a></li>
	<li id="menu-item-2507" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2507"><a href="http://vmusketeers.com/manny-sidhu/">Manny Sidhu</a></li>
	<li id="menu-item-384" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-384"><a href="http://vmusketeers.com/shady-ali-elmalatawey/">Shady Ali ElMalatawey</a></li>
</ul>
</li>
<li id="menu-item-231" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231"><a href="http://vmusketeers.com/contact-us/">Contact Us</a></li>
</ul></div>		</nav>
	</div>
</header><div class="mh-container mh-container-outer">
<div class="mh-wrapper clearfix">
	<div id="main-content" class="mh-content"><article id="post-3255" class="post-3255 post type-post status-publish format-standard hentry category-design category-vcdx category-vmware">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			Mapping the VCDX Defense Genome Part 3: Is All Flash a Trap?!		</h1>
		<p class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="http://vmusketeers.com/2018/01/">January 5, 2018</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="http://vmusketeers.com/author/jgrierson/">Jason Grierson</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="http://vmusketeers.com/category/design/" rel="category tag">Design</a>, <a href="http://vmusketeers.com/category/vcdx/" rel="category tag">VCDX</a>, <a href="http://vmusketeers.com/category/vmware/" rel="category tag">VMware</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a class="mh-comment-scroll" href="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/#mh-comments">0</a></span>
</p>
	</header>
		<div class="entry-content clearfix">
				<p>Hey everyone,</p>
<p>So prior to the holidays I was helping mentor some new VCDX candidates for their re-defenses and was coming across a few trends that I wanted to discuss a little as they started creeping up over and over again.  These trends were All Flash SAN’s, Oversized Compute, and questions being asked that were not part of the candidates design.  We’ll get into the last point a little more but first lest tackle the first two.</p>
<p>All Flash SAN</p>
<p><img class="alignnone wp-image-3260" src="https://i1.wp.com/vmusketeers.com/wp-content/uploads/2018/01/ItsATrap.png?resize=516%2C392" alt="ItsATrap" srcset="https://i1.wp.com/vmusketeers.com/wp-content/uploads/2018/01/ItsATrap.png?w=832 832w, https://i1.wp.com/vmusketeers.com/wp-content/uploads/2018/01/ItsATrap.png?resize=300%2C228 300w, https://i1.wp.com/vmusketeers.com/wp-content/uploads/2018/01/ItsATrap.png?resize=768%2C583 768w, https://i1.wp.com/vmusketeers.com/wp-content/uploads/2018/01/ItsATrap.png?resize=80%2C60 80w" sizes="(max-width: 516px) 100vw, 516px" data-recalc-dims="1" /></p>
<p>Is All Flash SAN a VCDX trap?  No of course not the All Flash SAN is obviously a silver bullet when it comes to storage as it greatly reduces the complexity of the storage system while giving amazing performance.  Gone are the days of tiering storage down to the last IOPS, automatic SAN storage migrations for hot data, and hybrid SAN’s, however it comes at a cost.   Although costs are constantly dropping it typically comes at a higher cost when it comes to money and also has some pit falls as far as a VCDX defense goes.</p>
<p>First let’s look Pro’s of an all Flash SAN and how you can defend its cost:</p>
<ul>
<li>Extremely high performance</li>
<li>Can run any IOPS load from small to large</li>
<li>Reduces administrative overhead as you have less tiers of storage or pools of disk to administrate, create hot spares for, etc, etc</li>
<li>Generally runs into less noisy neighbor issues, and peak spike issues</li>
<li>Future proof’s the SAN from a performance stand point</li>
</ul>
<p>Now let’s look at some requirements and or constraints this could fulfill</p>
<ul>
<li>R001: must reduce storage overall management</li>
<li>R002: storage must be able to handle all applications and future infrastructure projects without negative performance impact</li>
<li>C001: small storage team requires simple storage design</li>
<li>C002: storage must be able to handle 20,000 IOPS at peak load times</li>
<li>C003: Budget Constraints</li>
</ul>
<p>Now let’s look at some con’s of an all Flash SAN</p>
<ul>
<li>Cost, typically All Flash SAN’s work out to be more expensive then a hybrid SAN or other SAN solutions, however this is a moving target as prices drop</li>
<li>Simpler design which can lead to problems in the defense, we’ll talk about this in a little bit</li>
</ul>
<p>Let’s break this out into a design decision table</p>
<table width="0">
<tbody>
<tr>
<td width="107"><strong>Decision</strong></td>
<td width="458"><strong>Description</strong></td>
</tr>
<tr>
<td width="107"><strong> 1.0</strong></td>
<td width="458"><strong>SAN – All Flash Vs Hybrid Storage</strong></td>
</tr>
<tr>
<td width="107">Decision &amp;</p>
<p>Justification</td>
<td width="458">All flash SAN will provide the best performance, while reducing complexity and management overhead.</p>
<p>A standard or hybrid SAN could fulfill the customer’s requirements however while maintain budget concerns but would not simplify the design or reduce management overhead for the small storage team.</td>
</tr>
<tr>
<td width="107">Assumptions</td>
<td width="458">Sufficient rack space and switch connections</td>
</tr>
<tr>
<td width="107">Constraints</td>
<td width="458">Small Storage Team, budget constraints</td>
</tr>
<tr>
<td width="107">Risks &amp; Considerations</td>
<td width="458">SPoF, Cost</td>
</tr>
<tr>
<td width="107">Containment</td>
<td width="458">SPOF – Using only one SAN is a SPOF.  This RISK is present in the current environment and has been accepted.  This can be mitigated by implementing a DR site or purchasing another SAN.</p>
<p>Cost – The All Flash Array cost more and will cost more for future expansions if required.  This risk has been accepted due to simplicity of the design, reduction in management, and future proofing in performance considerations.  This risk could be mitigated with a hyper converged option like VSAN or a slower disk SAN for other workloads at a lower cost.</td>
</tr>
<tr>
<td width="107">Requirements Met</td>
<td width="458"> R001, R002, C001,C002</td>
</tr>
<tr>
<td width="107">Design Qualities</td>
<td width="458"> Manageability, Performance</td>
</tr>
</tbody>
</table>
<p>Table #1 Donated by Kiran Reid VCDX#225</p>
<p>So as you can see this can be easily defended but the pit fall is due to the characteristics of an All Flash Array it can also be used as an easy catch all.  This is where you might find some questions that don’t involve your design come up in your defense that you were not expecting. This is because things like SOIC, Noisy Neighbor, IOPS sizing, storage pools, Storage DRS, Storage policies, and other deep technical design considerations that typically would show up with a traditional storage array don’t come into the picture.  So to give the candidate a chance to score points you may be asked these questions even though it has nothing to do with your design from a storage perspective.</p>
<p>At the end of the day you have to remember the VCDX is still an exam and the defense panel has a rubric they will be scoring you against.  So if the storage section in the rubric has scoring points for these sections and your design is lacking in these area’s or doesn’t include them because they are not required due to an All Flash Array you may see questions come up that you were not expecting.</p>
<p>So how can you prepare for this?  Make sure you have your design decisions ready to defend the All Flash array both from a design/technical level and also from a business level aligning with AMRPS.  You may also want some back up slides with other storage considerations for the design as talking points or just be prepared to speak technically or at a design level for the other storage considerations.  As the panelists are checking to make sure you have a solid storage understanding from end to end.</p>
<p>Now onto the oversized compute side.</p>
<p><img class="alignnone size-full wp-image-3261" src="https://i0.wp.com/vmusketeers.com/wp-content/uploads/2018/01/LargeDatacenter.png?resize=678%2C457" alt="LargeDatacenter" srcset="https://i0.wp.com/vmusketeers.com/wp-content/uploads/2018/01/LargeDatacenter.png?w=753 753w, https://i0.wp.com/vmusketeers.com/wp-content/uploads/2018/01/LargeDatacenter.png?resize=300%2C202 300w" sizes="(max-width: 678px) 100vw, 678px" data-recalc-dims="1" /></p>
<p>So I only needed 48 cores of processing power and 1TB of memory, but I got a DEAL!</p>
<p>We run into some of the same issues with over sizing compute.  Mostly with it being a catch all instead of “sizing accordingly”  However in most cases most companies when they buy compute they are buying it for 5 years and typically when they go to the well they only want to go to the well once if possible.  So they will buy big or over size.  Or there could be a number of other reason as to why more hardware was purchased just to list a few:</p>
<ul>
<li>Server promotion</li>
<li>Buy one get one</li>
<li>Q4 sale</li>
<li>Vendor sales person having a bad quarter and just NEEDS something</li>
<li>Buying in bulk</li>
</ul>
<p>I’m sure there is many more.  This again can be defended as a VCDX design decision but will require some additional considerations.  Let’s create some requirements and constraints to break this down in the design decision table again.</p>
<ul>
<li>R001: must meet current compute sizing based off current state analysis plus 5 years growth at 20% a year growth</li>
<li>R002: must be able to absorb newly acquired companies as part of expansion plan</li>
<li>R003: must be able to meet application SLA’s during peak usage</li>
<li>R004: Reduce management overhead where possible</li>
<li>C001: Solution must have consistency and stick with one vendor</li>
<li>C002: Budget Constraints</li>
</ul>
<p>&nbsp;</p>
<table width="0">
<tbody>
<tr>
<td width="107"><strong>Decision</strong></td>
<td width="458"><strong>Description</strong></td>
</tr>
<tr>
<td width="107"><strong> 2.0</strong></td>
<td width="458"><strong>Compute – 24 Blades vs 12 Blade deployment</strong></td>
</tr>
<tr>
<td width="107">Decision &amp;</p>
<p>Justification</td>
<td width="458">24 Blades was selected and accepted as the solution to meet the current requirements as it could more easily absorb the 20% year growth with the unknown additional growth of new company acquisitions as part of the company’s expansion plan.</p>
<p>12 blades could have been used to meet the requirements however this would of introduced additional risk due to R002 ambiguity in sizing information.   This could lead to additional sudden compute purchased which lead to a larger upfront purchase decision.</td>
</tr>
<tr>
<td width="107">Assumptions</td>
<td width="458">Sufficient rack space and switch connections</td>
</tr>
<tr>
<td width="107">Constraints</td>
<td width="458">Compute solution must have consistency and one vendor, budget constraints</td>
</tr>
<tr>
<td width="107">Risks &amp; Considerations</td>
<td width="458">Cost</td>
</tr>
<tr>
<td width="107">Containment</td>
<td width="458">Cost – Purchasing 24 blades over 12 blades violated C002 budget constraints, however by purchasing 24 blades it reduced the risk of R002 while being able to better fulfill R003 and R001.  Reducing R002 risk could also lead to a lower TCO as last minute compute purchases could lead to higher overall costs.  This risk, constraint violation and risk mitigation plan was all accepted.</p>
<p>By sticking with one vendor and buying models all at the same time this will remove additional patching, firmware, and update management</td>
</tr>
<tr>
<td width="107">Requirements Met</td>
<td width="458"> R001, R002, R003, R004, C001</td>
</tr>
<tr>
<td width="107">Design Qualities</td>
<td width="458"> Manageability, Performance, Availability</td>
</tr>
</tbody>
</table>
<p>Table #2 Donated by Kiran Reid VCDX#225</p>
<p>So again we can defend this design decision based off AMRPS and requirements / constraints, but we you will also need to be prepared to answer questions around the standard compute questions like vCPU ratios, NUMA, Resource Pools, limits, Admission controls, TPS, and how these all get effected by having  large compute cluster.  Many times we can fall into the trap and avoid a lot of these hard compute design choices by over buying but just be ready to answer these both if they are in your design and if they are not.</p>
<p>I was going to try and fit another discussion piece on the VCDX is still and exam how it could be broken down from a point’s perspective but seeing as this blog post is already getting longer I’m going to break that out into the next one, so stay tuned for Mapping the VCDX Genome Part 4: Points breakdown</p>
<p>So in conclusion if you use an All Flash Array be prepared to possibly answer sizing questions on a traditional array / process to score additional points.   If you have an oversized compute design choice also be prepared to answer questions on how this can affect the technical design choices.</p>
<p>As always discuss encouraged and any feedback is always welcome</p>
<p>Till next time!</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-3255" class="share-twitter sd-button share-icon" href="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-3255" class="share-linkedin sd-button share-icon" href="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-3255" class="share-google-plus-1 sd-button share-icon" href="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-3255" class="share-facebook sd-button share-icon" href="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>	</div>
		</article><nav class="mh-post-nav-wrap clearfix" role="navigation">
<div class="mh-post-nav-prev mh-post-nav">
<a href="http://vmusketeers.com/2017/12/20/ravello-windows-vcenter-6-5-vcenter-server-errors-500-503/" rel="prev">Previous article</a></div>
</nav>
<h4 id="mh-comments" class="mh-section-title mh-comment-form-title">Be the first to comment</h4>
		
		<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/#respond" style="display:none;">Cancel reply</a></small></h3>
			<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=110756148&#038;postid=3255&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.6&#038;sig=1e11e86b9028be41588d31a3305e9eaa90840f17#parent=http%3A%2F%2Fvmusketeers.com%2F2018%2F01%2F05%2Fmapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap%2F" allowtransparency="false" style="width:100%; height: 430px;border:0;" frameBorder="0" scrolling="no" name="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

			</div>
	<aside class="mh-widget-col-1 mh-sidebar"><div id="blog_subscription-3" class="mh-widget jetpack_subscription_widget">			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				<div id="subscribe-text"></div><p>Join 53 other subscribers</p>
					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-3">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-3" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="http://vmusketeers.com/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-3" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-3]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-3'),
					input = d.getElementById('subscribe-field-blog_subscription-3'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</div><div id="search-2" class="mh-widget widget_search"><form role="search" method="get" class="search-form" action="http://vmusketeers.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="widget_sp_image-6" class="mh-widget widget_sp_image"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">vSphere 6.5</span></h4><a href="https://www.vmware.com/support/pubs/vsphere-esxi-vcenter-server-6-pubs.html?src=vmw_so_vex_kbott_1021" target="_blank" class="widget_sp_image-image-link" title="vSphere 6.5"><img width="642" height="363" alt="vSphere 6.5" class="attachment-full" style="max-width: 100%;" srcset="https://i1.wp.com/vmusketeers.com/wp-content/uploads/2016/11/vsphere-6.5.jpg?w=642 642w, https://i1.wp.com/vmusketeers.com/wp-content/uploads/2016/11/vsphere-6.5.jpg?resize=300%2C170 300w" sizes="(max-width: 642px) 100vw, 642px" src="https://i1.wp.com/vmusketeers.com/wp-content/uploads/2016/11/vsphere-6.5.jpg?fit=642%2C363" /></a></div><div id="widget_sp_image-8" class="mh-widget widget_sp_image"><a href="http://labs.hol.vmware.com/HOL/catalogs?src=vmw_so_vex_kbott_1021" target="_self" class="widget_sp_image-image-link"><img width="400" height="229" class="attachment-400x229" style="max-width: 100%;" src="http://vmusketeers.com/blog/wp-content/uploads/2016/04/HOL.jpg" /></a></div><div id="googleplus-badge-2" class="mh-widget widget_googleplus_badge"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">VCAP6-DCV Design</span></h4><div class="g-community" data-href="https://plus.google.com/communities/101159195928964402221" data-layout="landscape" data-theme="dark" data-showphoto="true" data-showowners="true" data-showtagline="false" data-width="220"></div></div><div id="googleplus-badge-3" class="mh-widget widget_googleplus_badge"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">VCAP6-DCV Deployment</span></h4><div class="g-community" data-href="https://plus.google.com/communities/108002000588564278612" data-layout="landscape" data-theme="dark" data-showphoto="true" data-showowners="true" data-showtagline="false" data-width="220"></div></div><div id="text-3" class="mh-widget widget_text"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Visitor&#8217;s Map</span></h4>			<div class="textwidget"><script type="text/javascript" src="//rf.revolvermaps.com/0/0/7.js?i=51av5a5gbmj&amp;m=0&amp;c=ff0000&amp;cr1=ffffff&amp;sx=0" async="async"></script></div>
		</div><div id="wpstatistics_widget-2" class="mh-widget widget_wpstatistics_widget"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Blog Statistics</span></h4><ul><li><label>Online Users: </label>0</li><li><label>Today's Visits: </label>186</li><li><label>Last 7 Days Visits: </label>9,540</li><li><label>Last 30 Days Visits: </label>40,338</li><li><label>Last 365 Days Visits: </label>453,840</li></ul></div></aside></div>
</div><!-- .mh-container-outer -->
<footer class="mh-footer">
	<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
					<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-1">
				<div id="wpc_image-3" class="mh-footer-widget widget_wpc_image">
</div>			</div>
									</div>
</footer>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">Copyright &copy; 2018 | WordPress Theme by <a href="http://www.mhthemes.com/" rel="nofollow">MH Themes</a></p>
	</div>
</div>

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5FBHLM"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/vmusketeers.com\/2018\/01\/05\/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap\/":3255};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2018/01/05/mapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://vmusketeers.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/drawit/js/drawit-iframe.js?ver=1.1.3'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201801'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/simple-ajax-chat/resources/sac.php'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/vmusketeers.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.7'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-includes/js/comment-reply.min.js?ver=4.6.9'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-includes/js/wp-embed.min.js?ver=4.6.9'></script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://vmusketeers.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.6'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=110756148&postid=3255&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=1e11e86b9028be41588d31a3305e9eaa90840f17#parent=http%3A%2F%2Fvmusketeers.com%2F2018%2F01%2F05%2Fmapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=110756148&postid=3255&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=1e11e86b9028be41588d31a3305e9eaa90840f17#parent=http%3A%2F%2Fvmusketeers.com%2F2018%2F01%2F05%2Fmapping-the-vcdx-defense-genome-part-3-is-all-flash-a-trap%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201801.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.6',blog:'110756148',post:'3255',tz:'0',srv:'vmusketeers.com'} ]);
	_stq.push([ 'clickTrackerInit', '110756148', '3255' ]);
</script>
</body>
</html>
<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

 Served from: vmusketeers.com @ 2018-01-06 01:37:49 by W3 Total Cache -->